Error 500

Oct 28, 2008 at 1:42 AM
  Hi,
I looked at all these discussions, including the one on "Flajaxian S3 File Uploader Errors and Debugging".
The guy on that thread didn't respond to say if the FULL CONTROL thing solved his problem.
Either way I get a 500 error all the time.
I have an existing PHP S3 uploader which works fine, dumping files to an existing S3 bucket.

I followed the setup exactly for FLAJAXIAN, but still I get the 500 error. Do you have any other idea why I might be getting this?
I am completely stumped! I tried fiddler and it didn't really give me any more information, it just shows the full .NET error page as shown below.

Any help would be appreciated, this looks like a great little control if I can get it working.
(I did try the regular FileUpload control previously and that works fine) 

Server Error in '/Uploader' Application.


The remote server returned an error: (500) Internal Server Error.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Net.WebException: The remote server returned an error: (500) Internal Server Error.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[WebException: The remote server returned an error: (500) Internal Server Error.]
   System.Net.HttpWebRequest.GetResponse() +1532114
   com.flajaxian.Dime.DimeManager.SendRequest() +290
   com.flajaxian.AWS.AmazonPutObjectService.CallService(Stream fileStream, String fileName) +717
   com.flajaxian.AWS.AmazonUploader.ProcessFile(HttpPostedFile file, Hashtable state) +250
   com.flajaxian.FileUploader.ProcessFiles(HttpFileCollection files) +190
   com.flajaxian.FileUploader.OnLoad(EventArgs e) +134
   System.Web.UI.Control.LoadRecursive() +47
   System.Web.UI.Control.LoadRecursive() +131
   System.Web.UI.Control.LoadRecursive() +131
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1436


Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433
<!-- [WebException]: The remote server returned an error: (500) Internal Server Error. at System.Net.HttpWebRequest.GetResponse() at com.flajaxian.Dime.DimeManager.SendRequest() at com.flajaxian.AWS.AmazonPutObjectService.CallService(Stream fileStream, String fileName) at com.flajaxian.AWS.AmazonUploader.ProcessFile(HttpPostedFile file, Hashtable state) at com.flajaxian.FileUploader.ProcessFiles(HttpFileCollection files) at com.flajaxian.FileUploader.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) [HttpUnhandledException]: Exception of type 'System.Web.HttpUnhandledException' was thrown. at System.Web.UI.Page.HandleError(Exception e) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest() at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) at System.Web.UI.Page.ProcessRequest(HttpContext context) at ASP.default_aspx.ProcessRequest(HttpContext context) in c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\uploader\21682fab\3c4d34c2\App_Web_jqnucphr.0.cs:line 0 at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) -->
Coordinator
Oct 28, 2008 at 5:23 AM
Do not give FULL CONTROL to everyone! Amazon doesn't allow such generosity.
Oct 28, 2008 at 12:23 PM
Hi,
  I'm sorry I guess I wasn't clear. I was NOT giving FULL CONTROL to all users like the previous guy was....that is just plain crazy ;-)

I set up the page EXACTLY as you have it in the example in the help file.
I have downloaded the latest DLL's as well.
Like I said I have a functioning bucket in S3 that I use a PHP uploader with.

Really, it seems very simple and there shouldn't be a problem...but yet there is one!
The only thing I can possibly think of is that my SECRET KEY has a "/" in it lke this:

.... BKI/VGJ83F


Are all secret keys formatted like this? But then you would think I'd get some other response from amazon, not a 500 error.
(It works fine in PHP) Actually I just tried entering completely false KEY information and I get the 500 error anyway.
Should an authentication error be returned?

Anyway if you have any insight into why this is happening I'd appreciate it!
Coordinator
Oct 28, 2008 at 6:32 PM
Edited Oct 28, 2008 at 6:33 PM
I have the same character in my secret key and it works. If the error was somewhere else in the stack we could assume it might be a control bug but if it's when you get the response it must be some kind of misconfiguration. Check your keys. Check your bucket name.
Oct 28, 2008 at 8:22 PM

Ok well thanks for the response!

I'll double check my keys (still don't get it since my php uploader works with the same info)
I tried on 2 different PC's at 2 different locations, one using VS2008, the other using VS EXpress.

Anyway I'll post here if I figure it out! Thanks for your responses!

Dec 3, 2008 at 3:23 PM
Add the following to your System.Web node in the web.config..


<webServices>
      <protocols>
        <add name="HttpGet"/>
        <add name="HttpPost"/>
      </protocols>
    </webServices>