Direct Amazon Uploader: Trouble with SSL

Apr 9, 2009 at 8:49 PM
Hello,

I am trying to use the Direct Amazon Uploader on a secure site (i.e. https), but I have run into a problem. I am unable to upload any file to Amazon, When I am in Firefox3, the flash returns a status of 5 (i.e. Error), but I am not sure how to retrieve any information about the error. When I am in IE7, I always get the following flash error:

Error #2044: Unhandled SecurityErrorEvent:. text=Error #2049: Security sandbox violation: https://my.domain.com/WebResource.axd?d=a3Jh-5_nXw5642uwZgNEV3km8MkjGeajxhvm5qMD3Cz-wtfcyvlPOh39XhuCSKZB2C_zImY9n7dl5WnEF59i4Sw0yUj6nOes23IaQBsNXas1&t=633722256000000000 cannot upload data to https://my.bucket.s3.amazonaws.com/.

As described in the doc, I have uploaded the following crossdomain.xml to the root of my.bucket.s3.amazonaws.com and made it public-readable:

<?xml version="1.0"?>
<!DOCTYPE cross-domain-policy SYSTEM
"http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
<cross-domain-policy>
     <allow-access-from domain="*" secure="false" />
</
cross-domain-policy>

I have tried using Fiddler to inspect the request the flash is sending to Amazon, but it is secure. Any help would be greatly appreciated. Thanks.

Sincerely,
-- Ryan Triggs

 

Coordinator
Apr 9, 2009 at 9:56 PM
If you use HTTPS allow-access-from domain secure atribute must be set to true
Apr 13, 2009 at 1:42 PM
I've changed secure to be true, but I still see the exact same error.
Coordinator
Apr 13, 2009 at 4:35 PM
You either don't have crossdomain.xml on the right place or it is not accessible from outside. There is no other way.
Coordinator
Apr 13, 2009 at 4:37 PM
And I see you have some dot after https://my.bucket.s3.amazonaws.com/ What is that the end of your sentance or the name of your folder? That may be it as well.
Apr 13, 2009 at 4:42 PM
Edited Apr 14, 2009 at 3:50 PM
The period was in the flash error message. Here is the location of my crossdomain.xml (url remove for privacy purposes) and I am trying to upload a file to the same bucket.
Coordinator
Apr 14, 2009 at 7:52 AM
You don't have secure sertificate - that seems to be the problem.
Apr 14, 2009 at 3:52 PM
Ah! I changed the bucket from "my.bucket" to "my-bucket" and the problem went away. Thanks for your help. I really appreciate it.