S3 Direct Uploader not working

May 22, 2009 at 12:13 PM

Hi,

I tried the free version of your control and it worked beautifully.  I need to update a database after the file is uploaded so I purchased the direct uploader.  After following your directions I can not get the control to work.  I can browse for a file to upload, however when I click on the upload button nothing happens.  To see this in action goto www.nxteam.net/s3upload.aspx.

This is the code for that page:

<%@ Page Language="VB" AutoEventWireup="false" CodeFile="S3Upload.aspx.vb" Inherits="S3Upload" %>
<%@ Register TagPrefix="fjx" Namespace="com.flajaxian" Assembly="com.flajaxian.FileUploader" %>
<%@ Register TagPrefix="fjx" Namespace="com.flajaxian" Assembly="com.flajaxian.DirectAmazonUploader" %>


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
        <table width="100%">
             <tr>
                <td valign="top" style="text-align: right; width: 50%">
                    <asp:Label ID="lblDescript" runat="server" Text="Description:" Font-Bold="True"
                        Font-Names="Verdana" Font-Size="8.4pt" />
                </td>
                <td style="width: 25%">
                    <asp:TextBox ID="txtDescript" runat="server" width= "50%" TextMode="MultiLine" />
                </td>
            </tr>
            <tr>
                <td valign="top" style="text-align: right; width: 50%">
                    <asp:Label ID="lblType" runat="server" Text="Attachment Type:" Font-Bold="True"
                        Font-Names="Verdana" Font-Size="8.4pt" />
                </td>
                <td style="width: 50%">
                    <asp:DropDownList ID="ddlTypes" runat="server" AutoPostBack="true">
                        <asp:ListItem Text="Choose" Value="0"></asp:ListItem>
                        <asp:ListItem Text="Photo" Value="PHOTO"></asp:ListItem>
                        <asp:ListItem Text="Insurance card" Value="CARD"></asp:ListItem>
                        <asp:ListItem Text="Xray" Value="XRAY"></asp:ListItem>
                        <asp:ListItem Text="MRI" Value="MRI"></asp:ListItem>
                        <asp:ListItem Text="PDF" Value="PDF"></asp:ListItem>
                        <asp:ListItem Text="Document" Value="DOC"></asp:ListItem>
                        <asp:ListItem Text="Spreadsheet" Value="XLS"></asp:ListItem>
                        <asp:ListItem Text="Audio File" Value="AUDIO"></asp:ListItem>
                        <asp:ListItem Text="Video File" Value="VIDEO"></asp:ListItem>
                        <asp:ListItem Text="Other" Value="OTHER"></asp:ListItem>
                    </asp:DropDownList>
                </td>
               
            </tr>
            <tr>
                <td valign="top" style="text-align: right; width: 50%">
                    <asp:Label ID="Label1" runat="server" Text="Select File:" Font-Bold="True"
                        Font-Names="Verdana" Font-Size="8.4pt" />
                </td>
                <td style="width: 50%">
                    <fjx:FileUploader ID="FileUploader1" runat="server">
                        <Adapters>
                            <fjx:DirectAmazonUploader
                                AccessKey="WebConfig:AmazonAccessKey"
                                SecretKey="WebConfig:AmazonSecretKey"
                                BucketName="NXMed"  />
                              

                        </Adapters>
                    </fjx:FileUploader>
                </td>
            </tr>
            <tr>
                <td style="width: 50%; text-align: right">
                    <asp:Label ID="lblStatus" runat="server" Font-Bold="True" Font-Names="Verdana"
                        Font-Size="8.4pt" ForeColor="#CC0000" />
                </td>
                <td style="width: 50%; text-align: left">
                    <input id="btnClose" type="button" value="Close" style="width: 80%; font-family: Verdana; font-size: 8.4pt; background-color: #586F9B; color: white" onclick="javascript:window.parent.myAttachments.Close();"  />
                </td>
            </tr>
         </table>
        
         
      
    </div>
    </form>
</body>
</html>

I used the exact crossdomain.xml file in your directions, copied it to the bucket mentioned in the code and gave all users full access to that file.

What am i overlooking?

Thnk You

Coordinator
May 22, 2009 at 1:10 PM

Please read the messages you have as response from the server. This is your response, it is quite clear:

<?xml version="1.0" encoding="UTF-8"?>

<Error>

<Code>NoSuchBucket</Code>

<Message>The specified bucket does not exist</Message>

<BucketName>nxmed</BucketName>

<RequestId>....</RequestId>

<HostId>...</HostId>

</Error>

To see the message use Fiddler http://www.fiddler2.com/Fiddler2/version.asp


May 22, 2009 at 1:57 PM

Thank you very much.  I didn't give all users Read rights to the bucket.